PDA

View Full Version : Processing square artifacts - any way to avoid ?



String
September 10th, 2004, 11:21 AM
Im playing with post photograph processing with paint shop pro 9 and photoshop but running against a brick wall.

The PSP "one step photo fix" seems to help some photos an awful lot however the blue water takes on a sometimes blocky appearance after some of the processing.

Trying similar enhancements in photoshop produces similar results.

Is this an unavoidable consequence of image processing or are there techniques im missing to avoid this ?

http://string.whitcombe.org.uk/files/turtle-original.jpg

is the original image. Notice the washed out green appearance i want to get rid of.

http://string.whitcombe.org.uk/files/turtle-1step.jpg

is the PSP one step click alteration, note the blockiness the water at the top takes on. I got a similar result with photoshop.

It *appears* to be the auto contrast adjust causing this but contrast needs to be altered to bring out the image.


Can anyone suggest another method of processing this image or similar images as ive got a lot of photos that look like this and go blocky ?

fdog
September 13th, 2004, 09:59 AM
This is standard results from jpg compression, and how it interprets image chip noise. For UW photos it's especially visible in huge chunks of water.

jpg is notorious for reducing color depth in the blue end of the spectrum, which is what you need to correct for the green.

I manipulate jpg images only with zero compression, thus making then huge. Compression is only applied as a last step prior to placing on the web or emailing them.

You might try converting to tiff and manipulating, then converting back to jpg.

All the best, James

PapaBob
September 13th, 2004, 10:37 PM
I loaded your turtlepic into photoshop. I first checked the image detail in the red channel and noted that it is sparse. The green channel is brighter and has detail. The blue channel is the brightest with good detail.

A picture with poor reds (looks splotchy in the red channel) can do well with a Mandrake adjustment. I did not undertake a Mandrake on your pic. Instead I made a new layer>layer via copy to work on with the levels commands. I do not adjust levels in RGB mode but in the individual color channels. I started with red channel and pulled in the highlight marker to the bottom of the histogram curve. I then fiddled with the middle slider until I produced the red I want without red overpowering the shot.

Next to the green channel. I set the endpoints on the histogram first and then pull the midrange slider to reduce the green, which makes the water much bluer, until I got the result I wanted.

Then to the blue channel. I set the endpoints and moved the midrange slider (gently) to get the final color balance. You can go back and tweak each step if you want.

Now I like the reef color and the turtle but the ocean background has become a bit noisy (your complaint). I used the navigator to zoom in. A lot of this noise is color noise present in other parts of the picture too. To get rid of it, I apply the gaussian blur filter until I eliminate the color noise. It worked at a radius of 3 for me. Then I applied Edit>fade gaussian blur and selected color mode. You will still have some noise spots (you call them blocks) but you have now made them a uniform color.

I now select quickmask and mask the water but not the turtle and reef. I click on the icon to make the quickmask a selection. I apply a sharpen filter to the turtle and foreground. Amt 150% Radius 2.1 and Threshold 6 worked for me.

I then Select>inverse selection which gives me the blue ocean background. A median filter with a 7px radius will clean up most of the noise (clutter).

This is the result. Hope you enjoy it. I had fun with your photo.

---Bob


Search Engine Friendly URLs by vBSEO 3.6.1