• Welcome to ScubaBoard


  1. Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

    Benefits of registering include

    • Ability to post and comment on topics and discussions.
    • A Free photo gallery to share your dive photos with the world.
    • You can make this box go away

    Joining is quick and easy. Login or Register now by clicking on the button

DM5 cannot run on MacOS

Discussion in 'Suunto' started by lvicini, Oct 19, 2019.

  1. lvicini

    lvicini Garibaldi

    2
    0
    1
    Hello,
    I cannot find a way to properly install Suunto DM5 on MacOS 10.15 (Catalina).
    Once installed, the application crashes immediately.

    Any clue on how to get it running?

    Cheers
     
  2. fmerkel

    fmerkel Loggerhead Turtle

    # of Dives: 1,000 - 2,499
    Location: Salish Sea (Seattle)
    1,658
    628
    113
    Can't address the Mac, but strongly suggest you use another app than DM5. Trouble with it is pretty routine and support is all but non-existent.

    One option that works fine WITH support and updates is Subsurface.
     
  3. JMBL

    JMBL Solo Diver

    # of Dives: 500 - 999
    Location: France
    422
    160
    43
    I'd forget DM5, software designed by diving computer brands are, most of the time, pieces of junk. I'd give MacDive a try. Been using it for several years : easy to use, reliable and with great customer service. Worth the fee.
     
    doctormike likes this.
  4. pauldw

    pauldw Solo Diver

    385
    451
    63
    Nope. But I can say that it's possible for it to run on a Mac. Does on mine.
     
  5. azstinger11

    azstinger11 Barracuda

    # of Dives: 200 - 499
    Location: San Diego, CA
    269
    163
    43
    @pauldw Have you upgraded to macOS Catalina yet? If you haven't upgraded could you click on the apple logo in the top left -> About this Mac -> system report -> software -> applications -> look for suunto DM5 (it should say intel 64 yes or no), what does it say?

    I just tried to install it and doesn't open. I'm willing to bet its a 32 bit application and as such won't run on macOS Catalina. Maybe Suunto will update it to be 64 bit or just choose a different dive logging software. I second the recommendations for Mac Dive. If you want a free one subsurface isn't bad at all, I just prefer MacDive.

    Yikes I even tried reverting back to Mojave and it wouldn't run well.
     
  6. RogueClimber

    RogueClimber ScubaBoard Supporter ScubaBoard Supporter

    # of Dives: 25 - 49
    Location: Honolulu
    71
    51
    18

    I haven't gone to Catalina so I looked, and I can't even find it in the list of applications... Looked for Suunto, DM5, Dive.... ????
     
  7. lvicini

    lvicini Garibaldi

    2
    0
    1
    Hello,
    Thanks for all your pieces of advice. I am new to the Suunto ecosystem. I will try all applications you suggest.

    I noticed immediately the DM5 app was substandard, when it ask me to download a separate SW library after the first launch (Suunto developers, it's mega easy to integrate the libraries into the App).
    Somehow the App is not registering with MacOS. A bit of app unpacking is showing that the app is referencing older versions of the Mono library... My take, is that I am not doing the developers job to fix the app -> App directly to the bin.

    Now then, are there any ways to update Suunto Dive computer Firmware (I just purchased a Suunto D5)?
     
  8. David Pearson

    David Pearson Angel Fish

    # of Dives: 200 - 499
    Location: S61 4HT
    8
    1
    3
    I'm having exactly the same problems this morning. Went diving yesterday, want to load my logs, cant't and recently updated Mac to Catalina(10.15).

    DM5 never been very stable on my mac but always managed to get it running. So if i consider using another piece of software, any way to get the data of my existing logs from DM5. If so how?

    Any advice appreciated to either get DM5 running or recovering logs.

    Also, if you can't load DM5, how are we to go into EON settings?

    Just hangs with this message. Not acceptable from Suunto!

    Screenshot 2019-10-20 at 11.50.41.png
     

    Attached Files:

  9. David Pearson

    David Pearson Angel Fish

    # of Dives: 200 - 499
    Location: S61 4HT
    8
    1
    3
    Me too, not listed under the software applications but when I go into applications it is there. It does try to load but says loading mono, tried reloading mono, still no joy. Frustrating.
     
  10. KenGordon

    KenGordon Rebreather Pilot

    2,630
    1,392
    113
    I use DM5 quite a lot. I used to use it on a Mac but these days on a PC as the plummeting pound make buying a MacBook silly.

    When I was using it on the Mac I had a sense of humour failure with Suunto regarding the use of Mono. It is a high risk strategy and it looks like it may have broken them quite properly this time.

    See Running WinForms apps in x64 mode on macOS · Issue #6701 · mono/mono my favourite is the post from 21st September.

    I would expect some effort to be made to fix this by the various people involved with Mono. It may be the case that manually installing a very recent Mono before DM5 will help, although 1) I am guessing Suunto will use that 2) there may not be a version of Mono yet that works given that ticket is still open.

    One way out might be to install windows in a VM or Linux in a VM and try running the PC DM5 under Wine. I’d bet against these though due to the various coms layers needing work to connect to the Eon.
     

Share This Page