• Welcome to ScubaBoard


  1. Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

    Benefits of registering include

    • Ability to post and comment on topics and discussions.
    • A Free photo gallery to share your dive photos with the world.
    • You can make this box go away

    Joining is quick and easy. Login or Register now by clicking on the button

Mares icon hd malfunctioning

Discussion in 'Mares... Just add Water!' started by Nigel Bryant, Aug 17, 2019.

  1. Nigel Bryant

    Nigel Bryant Photographer

    # of Dives: 200 - 499
    Location: England
    26
    6
    3
    I have charged my icon to 100% but as soon as I dive the battery reading goes to 6%, starts losing % and then dies. This has now happened twice. Just charged it again ( from dead) and it went to 100% within ten minutes. Unplug it and within a minute it’s back to 6%. Help !!!
     
  2. AndrewStick

    AndrewStick Angel Fish

    # of Dives: 50 - 99
    Location: Moscow, Russia
    50
    24
    8
    I think your battery is dead.
     
  3. Nigel Bryant

    Nigel Bryant Photographer

    # of Dives: 200 - 499
    Location: England
    26
    6
    3
    It holds charge ok. It just drops to 6% when under water.
     
  4. Kharon

    Kharon Solo Diver

    # of Dives: 200 - 499
    Location: Upstate NY
    3,739
    3,038
    113
    If the battery charged in that length of time it's toast. Replace the battery. LeisurePro has them and it's a piece of cake. Just remember to not which wire goes where before you unplug it.
     
  5. Naboodiver

    Naboodiver Nassau Grouper

    # of Dives: 200 - 499
    Location: Maryville, Tennessee
    130
    14
    18
    Same thing happened to mine. After a full night charge it was showing just 6% after taking off the charger. As always when I had problems with the ICON, I was on a dive trip, this time in Honduras. I had purchased a spare battery as Kharon said from Leisurepro as an insurance policy. I changed out the battery with the new one but it would not show a display and had no charge after being on the charger over night. Just a red blinking light at the bottom of the display. So the battery went bad or was defective. In the process of trying and retrying the install the battery, I completely destroyed the socket to which the battery is connected and now the ICON is a paper weight. I thought about trying to get it repaired but I figure the cost would be more and it was worth. Be very careful if you replace the battery yourself as the socket the battery terminal goes into is very fragile. I am now looking for as new computer. I think I will switch brands. I loved to Icons big display and thought about the Genius but had a lot of issues with the Icon over the years and I think it is time to move on to another brand.
     

Share This Page