• Welcome to ScubaBoard


  1. Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

    Benefits of registering include

    • Ability to post and comment on topics and discussions.
    • A Free photo gallery to share your dive photos with the world.
    • You can make this box go away

    Joining is quick and easy. Login or Register now by clicking on the button

Perdix AI and bluetooth...

Discussion in 'Shearwater Research' started by mwerle, Sep 1, 2019.

  1. mwerle

    mwerle Angel Fish

    # of Dives: 100 - 199
    Location: Tokyo, Japan
    37
    16
    8
    So a rather frustrating weekend later..

    Got my Perdix AI (firmware V65) delivered on Saturday morning and proceeded to have a play with my new toy, setting it and my PC up to configure everything and make sure it's all working.

    The Perdix itself seems to be fine, but its bluetooth compatibility and connectivity does not appear to be very robust.

    PC (Windows 10 1903) - haven't managed a successful connection at all. Tried both the build-in bluetooth as well as the supplied dongle, "Shearwater Desktop", "Shearwater Cloud", and "Subsurface". The PC worked fine with a Cosmiq+ (also using Bluetooth LE) as well as other bluetooth peripherals.

    Same PC with Linux (again, no problem with the Cosmiq+) using "Subsurface" it does manage to pair to the Perdix, but it fails to download the test dive.

    Work laptop (also Windows 10 1903) - initially seemed to work (built-in bluetooth) using "Shearwater Desktop", but has since also become hit-and-miss. Not sure if I was just lucky to start off with or what changed, but I did not install any updates. Overall works "sometimes" but not 100% reliably. Not really an option though as it's a work laptop.

    Phone (Samsung Galaxy Note 4) - "Subsurface" app managed to connect and download the test dive. "Shearwater Cloud" did not. Overall connectivity is not a given either but seems more stable than either PC or laptop.


    All of these devices work fine with each other, and worked fine with the Cosmiq+ (also using Bluetooth LE mode). I was not expecting this level of hassle with such an expensive device, especially as a much cheaper device worked flawlessly.

    Am I alone in this or are other people also having connectivity issues? While I found plenty of people having issues they all seem to be from a year or so ago when Microsoft released the "Creator" update, and whatever issue Microsoft introduced back then appears to have been fixed in the meantime.
     
    taimen and Protondecay123 like this.
  2. Fyffer

    Fyffer Nassau Grouper

    # of Dives: 0 - 24
    Location: Vancouver bc
    95
    36
    18
    I don’t know the answer but I’m sure in short time someone with The knowledge will post. It is a great computer.
     
  3. MargaritaMike

    MargaritaMike Divemaster

    # of Dives: 1,000 - 2,499
    Location: On a non-divable lake in SE Texas
    765
    581
    93
    I was unable to connect. Mark at Shearwater was working with me and suggested that I go into settings and delete the Perdix device. I did and everything worked. Don't know why but it did. Here is the email he sent me:

    Please press “Start” and search: “Bluetooth and other devices settings” and click on the icon with the same name.
    _9WL51OpwM1iYGBhk4bCNQ2JNoQaGkxGcV-kK6LyP3sf3bYIMXtrh4ILICbqp7fr_Vx_zq1VWWf0iR2pyorkaAVEy1Gnbk2W.png
    Once in here please remove any Shearwater Dive Computers you see in the list: “Other Devices”
    After that toggle the Bluetooth “Off” then “On” again
    iq24MyUHxj7UHaKJg9irP7yT9S8XbyPdruPJmQHoCmMA9pJWpBzoRfBzpHUmzOlPRGCGjQ8PdyuiV7k3rUDDf7biODkW1ZGh.png
    Please try connecting again after this, let me know if you continue experiencing difficulties.


    It worked.

    Cheers -
     
    mwerle, WinfieldNC and Protondecay123 like this.
  4. mwerle

    mwerle Angel Fish

    # of Dives: 100 - 199
    Location: Tokyo, Japan
    37
    16
    8
    Thanks; I tried that several times already. Standard IT troubleshooting: "Have you tried turning it off and on again?" LOL.

    I also tried completely uninstalling _ALL_ bluetooth related stuff (Using the old-style Device manager in Windows) and uninstalling the device drivers, rebooting and restarting everything from scratch. Weirdly it seems Windows never quite seems to "forget" Bluetooth devices; as soon as the device driver is reinstalled following a reboot, the devices pop up again even though they were deleted.

    But my issues aren't just Windows related; as I said, another laptop, Linux, and my phone are also having issues to varying degrees. Since things works fine with other devices, the culprit seems to be the actual Perdix that's being pernicky rather than everything else. So I was partially wondering whether other people are also having issues.
     
  5. Griffo

    Griffo DIR Practitioner

    # of Dives: 200 - 499
    Location: Sydney, Australia
    1,350
    637
    113
    Strange. I wonder if your unit has an actual issue.

    I did have problems pairing on Win10 Creators Update, but that was a known issue with 1709. My Android phone (OnePlus) and two different laptops work flawlessly with it on 1803.

    Have you contacted support?
     
  6. mwerle

    mwerle Angel Fish

    # of Dives: 100 - 199
    Location: Tokyo, Japan
    37
    16
    8
    Yes I have; figured I'd see if other people have similar issues and/or recommend other things to try while I wait for a reply.
     
  7. Griffo

    Griffo DIR Practitioner

    # of Dives: 200 - 499
    Location: Sydney, Australia
    1,350
    637
    113
    Personally i'd remove the battery for a few minutes, and then try to connect to it from the phone only first and see if it works reliably. I wonder if your laptop might be locking up the BT stack.
     
  8. MargaritaMike

    MargaritaMike Divemaster

    # of Dives: 1,000 - 2,499
    Location: On a non-divable lake in SE Texas
    765
    581
    93
    The common thread is the unit. SW should make it right. I realize that you are "convenient" to SW, but I have faith in them.
    Good luck -

    Cheers -
     
  9. KWS

    KWS ScubaBoard Supporter ScubaBoard Supporter

    # of Dives: 500 - 999
    Location: SE TEXAS
    4,269
    971
    113
    I HAD something like that problem and it was that the dongle was plugged into the wrong usb port. IE it did not like the usb 3 port but worked well with the usb 2 port.
     
    mwerle likes this.
  10. Seaweed Doc

    Seaweed Doc Marine Scientist

    # of Dives: 500 - 999
    Location: Seattle, Washington State, USA
    676
    425
    63
    I've only connected my Perdix to my Android phone. It links much more reliably than my Aqualung i300c. With the AL i300c, replacing the battery helped one time. That is, putting in a brand new battery.
     

Share This Page