• Welcome to ScubaBoard


  1. Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

    Benefits of registering include

    • Ability to post and comment on topics and discussions.
    • A Free photo gallery to share your dive photos with the world.
    • You can make this box go away

    Joining is quick and easy. Login or Register now by clicking on the button

S&S DX400D housing with YS-D1 strobe compatiblity problem.

Discussion in 'Sea&Sea Society' started by Grizlik, Feb 4, 2013.

  1. Grizlik

    Grizlik Angel Fish

    6
    0
    0
    Hello.
    I have old Sea & Sea DX400D housing (with built-in TTL controller) for Canon 400D (Digital Rebel XTi), and YS-110 strobes. All this equipment work fine in TTL-mode (via electrical cable). I bought new strobes - YS-D1 (more powerfull), and result are: some problems occurs in compatiblity between my housing (or may be TTL-controller) and new strobes. Problems: flash-compensation from camera not work, and TTL-confirmation lamp not confirm by green light. But TTL-exposition work normal. I think that the S&S engeneers changed the protocol in new strobe (that have DS-TTL-II now).
    Is anyone having ideas how can I solve this situation?
     
  2. Larry C

    Larry C Dive Con

    # of Dives:
    Location: SF Bay Area
    3,221
    150
    63
    The 400D is not on Sea & Sea's compatibility list for the YS-D1.
    SEA&SEA |
     
  3. Grizlik

    Grizlik Angel Fish

    6
    0
    0
    Problem solved. It is poor lithium battery (3V) in built-in controller. :) After changing to new battery TTL-controller works perfectly with YS-D1 strobes.
     

Share This Page