• Welcome to ScubaBoard


  1. Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

    Benefits of registering include

    • Ability to post and comment on topics and discussions.
    • A Free photo gallery to share your dive photos with the world.
    • You can make this box go away

    Joining is quick and easy. Login or Register now by clicking on the button

Slipping Comand Dial

Discussion in 'Sea&Sea' started by Jesper64, May 26, 2011.

  1. Jesper64

    Jesper64 Angel Fish

    12
    0
    0
    I have a problem with my DX-D80 where the subcommand dial intermittently works. When turning the subcommand dial on the housing it does not turn the subcommand dial on the camera. It is a combination of either the rubber disc slipping on the camera dial or the cogs in the housing slipping.

    Anyone had any experience with this or can suggest a remedy?

    I've circled the parts that I am talking about below.

    DX-D80 subcommand dial.jpg

    Cheers
     
  2. Jesper64

    Jesper64 Angel Fish

    12
    0
    0
    After a bit of tinkering with it I think the problem is due to the vertical shaft having some fore and aft play in it. When turning the housing wheel clockwise the shaft is pushed forward and that is fine. But when it is turned anticlockwise the vertical shaft shifts backwards a bit, which is enough to cause the gears to lock up. Though, I'm not 100% certain of this and would love to hear other people's thoughts.
     
  3. SEA&SEA

    SEA&SEA Dive Equipment Manufacturer

    427
    5
    18
    Jesper-
    Sorry for the delayed reply, if you are still looking for a solution or repair and are located in the US, please contact the following recommended service facilities: PHR or Backscatter. If you are out of the USA, you would need to contact your regional distributor or SEA&SEA Japan directly.
     
  4. Jesper64

    Jesper64 Angel Fish

    12
    0
    0
    Hi,
    Sorry for my tardy reply now :) Thanks for the information. Luckily, I've been able to adjust it a bit more and it's working nice and smoothly again.
     

Share This Page