• Welcome to ScubaBoard


  1. Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

    Benefits of registering include

    • Ability to post and comment on topics and discussions.
    • A Free photo gallery to share your dive photos with the world.
    • You can make this box go away

    Joining is quick and easy. Login or Register now by clicking on the button

Sola 1200 Video won't finish charging

Discussion in 'Light and Motion' started by Chuck Tribolet, Jul 4, 2013.

  1. Chuck Tribolet

    Chuck Tribolet Loggerhead Turtle Rest in Peace

    2,910
    109
    0
    I've got a Sola 1200 Video that won't finish charging. It stays flashing green forever.

    Any thoughts?

    ---------- Post added July 3rd, 2013 at 11:03 PM ----------

    It turns out it's the combination of light and charger that triggers this behavior. We have three Sola 1200s and three chargers. The problem Sola only has the problem on one charger. Another Sola seems to work fine on all three chargers. I haven't done an exhaustive test on the third Sola (it's all setup to dive tomorrow).
     
  2. drbill

    drbill The Lorax for the Kelp Forest Scuba Legend

    # of Dives: 2,500 - 4,999
    Location: Santa Catalina Island, CA
    22,436
    5,297
    113
    One of my Sola 1200s was doing that for about two months then it (probably just the battery) died last week. Hope your mileage varies. I did try my other charger and it wouldn't charge that unit.
     
  3. Chuck Tribolet

    Chuck Tribolet Loggerhead Turtle Rest in Peace

    2,910
    109
    0
    It turns out it's only the one combination of Sola and charger (out of three of each, so none combinations) that has the problem.
    MMM.
     
  4. lightandmotion

    lightandmotion Dive Equipment Manufacturer

    46
    6
    0
    Hi Chuck,
    There are a couple of possible causes here:
    First, make sure the light's contacts are clean and corrosion-free. Inadequate contact between charger and light can cause charging errors. If you find corrosion on the rear contacts, clean them with a few drops of 25% vinegar, 75% water, and use a mild abrasive like extra-fine polishing wool or the scrubbing side of a sponge to polish the corrosion off.

    It could also be that the charge counter is out of calibration, so the light is not registering when it has reached a full charge. To recalibrate, charge the light fully (three hours should do it), run it down in a bucket of water to keep it cool, then immediately charge it up. This procedure recalibrates the charge counter.
     
  5. Chuck Tribolet

    Chuck Tribolet Loggerhead Turtle Rest in Peace

    2,910
    109
    0
    No corrosion.

    How do I tell even the light has finished discharging?
     
  6. drbill

    drbill The Lorax for the Kelp Forest Scuba Legend

    # of Dives: 2,500 - 4,999
    Location: Santa Catalina Island, CA
    22,436
    5,297
    113
    Turned out my issue was that the one light had gone into travel shutdown mode. Blaise at L&M told me to just hold the switch in the forward position for four seconds and it would come out of it. It did.
     
  7. lightandmotion

    lightandmotion Dive Equipment Manufacturer

    46
    6
    0
    The light is finished discharging when it turns itself off.
     
  8. Chuck Tribolet

    Chuck Tribolet Loggerhead Turtle Rest in Peace

    2,910
    109
    0
    The discharge ran about five hours, roughly evenly split between green, yellow, red, and blinking red. This on a year-and-a-half old Video Sola on low flood. This particular Sola is a backup that has seen almost no use.

    It's now recharged and and ended the charge cycle as expected. This using the charger that gave it problems. All is now well.

    Thanks.
     

Share This Page