• Welcome to ScubaBoard


  1. Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

    Benefits of registering include

    • Ability to post and comment on topics and discussions.
    • A Free photo gallery to share your dive photos with the world.
    • You can make this box go away

    Joining is quick and easy. Login or Register now by clicking on the button

Sola Tech 600

Discussion in 'Light and Motion' started by Thor22, Apr 23, 2015.

  1. Thor22

    Thor22 Angel Fish

    # of Dives: 1,000 - 2,499
    Location: New Jersey
    5
    1
    3
    What's the depth rating on the Tech 600? I know the Sola 800 and 1200 are 270', just curious if the Tech is rated deeper? Thanks!
     
  2. RJP

    RJP Scuba Media & Publications

    # of Dives: 1,000 - 2,499
    Location: New Jersey
    13,460
    6,035
    113
    90m/295ft... per DRIS website anyway.
     
  3. lightandmotion

    lightandmotion Dive Equipment Manufacturer

    46
    6
    0
  4. Thor22

    Thor22 Angel Fish

    # of Dives: 1,000 - 2,499
    Location: New Jersey
    5
    1
    3
    Just received new tech 600...when connected to charge the light itself flashes and the charger alternates between a red/orange light to a green light. The indicator lights on the unit itself started flashing red as the manual indicated for a low/dead battery and eventually did turn to solid green (full charge). When attempting to turn the light on, it will not turn on by sliding the slider either up or down and letting go...when I do that the first green light illuminates and when I let go all three lights flash red. If I slide and hold the slider the light will stay on until the slider is released or until the 4 second lock out goes into effect. Is there a trick I'm missing or is this a defective light that needs to be returned?? Thanks so much!
     
  5. Monarch_15w

    Monarch_15w Angel Fish

    # of Dives: 100 - 199
    Location: Nebraska
    42
    0
    6

    Mine me did that same thing the motherboard basically stopped working and needed to be replaced sent if for a replacement and light and motion repaired light.
     

Share This Page