• Welcome to ScubaBoard

  1. Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

    Benefits of registering include

    • Ability to post and comment on topics and discussions.
    • A Free photo gallery to share your dive photos with the world.
    • You can make this box go away

    Joining is quick and easy. Login or Register now by clicking on the button

Tank leaking

Discussion in 'Hogarthian Diving' started by TigerDiver8, Sep 28, 2013.

  1. TigerDiver8

    TigerDiver8 Barracuda

    # of Dives: 500 - 999
    Location: Ventura County, California, United States
    266
    14
    18
    My AL80 is leaking air for about 5 sec (with some pressure might i add) out of the yoke adapter on my HOG D1 when initially turn the air on. I thought tank valve o ring at first, it looked fine when i pulled it out but changed it for a new one anyway. And it still does it. when the discharge stops it holds air fine, but just makes me nervous.Any ideas?
     
  2. Dsix36

    Dsix36 Solo Diver

    1,443
    950
    113
    I have no idea if this information will help or if it is relevant, but it sounds so similar that I figured that I would share it.

    Several people that I know were having a problem with their Apeks first stages sealing up when first turned on. They would leak like hell and force an immediate shut down but upon turning the tank back on they would hold just fine. It turns out that these divers were actually using an o-ring that was very slightly the wrong size. When they used the correct o-ring, problem solved.
     
  3. TigerDiver8

    TigerDiver8 Barracuda

    # of Dives: 500 - 999
    Location: Ventura County, California, United States
    266
    14
    18
    Thanks, I'm pretty sure I've got the right size o ring, but i will look into it. Its gotta be something with my tank and not my first stage, cause I've only got 5 dives on my new reg set up. And maybe this thread shouldn't be in this forum, just thought cause it was a HOG reg I would put it here.
     
  4. SC_Hoaty

    SC_Hoaty Solo Diver

    # of Dives: 25 - 49
    Location: SC
    5,594
    4,015
    0
    A better place would be Edge Gear since Edge makes our HOG regs. You can start a new thread there, or hit the report button on your initial post, and request a mod to move this thread over there. Your choice.
    Good luck solving an unusual problem! :cheers:
     
  5. Bob DBF

    Bob DBF Solo Diver

    # of Dives: I just don't log dives
    Location: NorCal
    6,549
    6,700
    113
    The Faber mid-pressure 72 I was using had a similar problem. It seems that they have an o-ring specific to their tank valve and a save-a-dive, one fits all, o-ring will leak sometimes. Eventually it will extrude and the fun begins. Found someone that knew the trick, got the right o-ring and it was good since.



    Bob
     
  6. KWS

    KWS ScubaBoard Supporter ScubaBoard Supporter

    # of Dives: 500 - 999
    Location: SE TEXAS
    4,396
    1,034
    113
    I had that problem with one of my regs. It was the oring used to seal the yolk to the reg. in my case it was the din to the reg. just screw the yolk securely into the reg or if tight change the seal. hope this is useful. wedge a screwdriver between inside of the yolk and the nut , then turn.
     

Share This Page