• Welcome to ScubaBoard


  1. Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

    Benefits of registering include

    • Ability to post and comment on topics and discussions.
    • A Free photo gallery to share your dive photos with the world.
    • You can make this box go away

    Joining is quick and easy. Login or Register now by clicking on the button

Solved: weird 404 errors

Discussion in 'Site Support' started by tep, Jun 17, 2017.

  1. Kohanbash

    Kohanbash Solo Diver

    # of Dives: 200 - 499
    Location: PA, USA
    119
    30
    This is happening with chrome on my iPhone last night and today.

    I click community then new posts, and get the 404. I press the back button and repeat that sequence and it works
     
  2. HowardE

    HowardE Diver Staff Member

    # of Dives: 2,500 - 4,999
    Location: Boca Raton, Florida
    19,202
    1,436
    There were some additional issues from the repaired apache rewrite rules that revealed incorrect links on the homepage. I changed those.

    If you have problems with scubaboard, you'll get a faster response by posting in site support than by emailing the support email.
     
    northernone and Bubblesong like this.
  3. tep

    tep ScubaBoard Supporter ScubaBoard Supporter

    # of Dives: 100 - 199
    Location: San Diego CA USA
    495
    193
    Things seem to be OK now, on the same computer/browser that were 404-ing before.

    Thanks!
     
  4. broncobowsher

    broncobowsher Solo Diver

    1,919
    1,397
    Still happening to me. But I did a little playing around and did find something. The links I used before (I go to the same places and just check a few specific forums) are 404ing me. Those have a link of
    www.scubaboard.com/forums/*****

    What is working now is a different address.
    www.scubaboard.com/community/forums/*****

    So somehow the addressing has gotten all jacked up. Where you could go directly before now requires a new address with the added "/community" in the middle. So if you start searching off the main page, you are getting a functional website. But going off prior links they are no longer valid.

    Don't know if this is everyone. But it has been working for me. Now to just go back and edit the shortcuts I have been using for years because someone wanted to get cute and change some naming.
     
  5. HowardE

    HowardE Diver Staff Member

    # of Dives: 2,500 - 4,999
    Location: Boca Raton, Florida
    19,202
    1,436
    Can you give me a specific example of one of the links so I can test it?

    I've made another small tweak to the rewrite rules, which I believe should have straightened this out.
     
  6. gopbroek

    gopbroek Solo Diver

    # of Dives: 1,000 - 2,499
    Location: Lewisville TX
    4,130
    4,912
    I was getting it earlier when using a bookmark to the Cozumel page. I went in manually and once there copied the URL and edited my bookmark. Since then no errors
    (using WIN7 and Explorer 11, locked down computer at work, on overtime)
     
  7. HowardE

    HowardE Diver Staff Member

    # of Dives: 2,500 - 4,999
    Location: Boca Raton, Florida
    19,202
    1,436
    Yes. I'm trying to verify that I've corrected the rewrite rule.

    If someone could try one of the old links that didn't work, yet would be great.

    Thanks
     
  8. TravisD

    TravisD Assistant Instructor

    # of Dives: 200 - 499
    Location: Westminster, MD
    699
    115
  9. HowardE

    HowardE Diver Staff Member

    # of Dives: 2,500 - 4,999
    Location: Boca Raton, Florida
    19,202
    1,436
    ok i think it works now.

    For whatever it's worth. All links to SB should be with https and www.

    Additionally, the forums base is currently /community/ vs /forums/ as it was with vBulletin. This was changed in January of 2016.
     
    NYCNaiad likes this.
  10. charlier

    charlier Marine Scientist

    # of Dives: I just don't log dives
    Location: Seattle/Singapore/Indonesia
    1,035
    605
    Howard - Thanks for the fix. Next time I have a support question, I will post in site support rather than using support email.
     

Share This Page