• Welcome to ScubaBoard


  1. Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

    Benefits of registering include

    • Ability to post and comment on topics and discussions.
    • A Free photo gallery to share your dive photos with the world.
    • You can make this box go away

    Joining is quick and easy. Login or Register now by clicking on the button

YS-D1 -- Blinks in green (not red-green)

Discussion in 'Sea&Sea' started by Meni Meller, Sep 28, 2012.

  1. Meni Meller

    Meni Meller Angel Fish

    # of Dives:
    Location: israel
    10
    1
    0
    Hi,

    When using the unit in manual mode or slave TTL it works perfectly.
    Using DS-TTL II with the Nikon P7000 works ok at some times, and locks the flash at other times.

    "Locks the strobe" means it starts blinking red/green (even after two shots on a fully charged battery set), turning the strobe off and then on again causes the LED to blink green only.
    Taking the battery cap out for about 10 seconds (strobe is fully dried after the dive) and putting it back in, causes the strobe to turn on normally and run for the rest of the batteries life, or until it gets locked again.

    I've uploaded a youtube video shows this behavior : DSCN0003 - YouTube .

    Are my units malfunctioned ? (this happens on both my units).
    Is this a firmware bug that can be fixed ?, perhaps adding the functionality equal to the "reset" while in-water ?

    Thanks,
    Meni.
     
  2. JackConnick

    JackConnick Optical Ocean Sales ScubaBoard Business Sponsor ScubaBoard Supporter

    1,760
    300
    83
    There are some known issues with bad battery life and TTL on a small amounts of these strobes. It should work ok in manual, but I would return it to your dealer for service/replacement.

    Jack
     
  3. Meni Meller

    Meni Meller Angel Fish

    # of Dives:
    Location: israel
    10
    1
    0
    Thanks Jack,

    I will contact my dealer.
    BTW, dry tests are always successful.
    I do hope i won't need to send my strobes for a long period of time only to receive them back as is..
     
  4. SEA&SEA

    SEA&SEA Dive Equipment Manufacturer

    427
    5
    18
    Hi Meni-
    As Jack mentioned, please return the strobe to your dealer or distributor for warranty replacement.
     
  5. Meni Meller

    Meni Meller Angel Fish

    # of Dives:
    Location: israel
    10
    1
    0
    I contacted the israeli distributor and was told that my strobes
    Will go through a firmware update. I.hope this does not involve opening the unit.

    A replacement is preferred inderd..

    Meni.
     
  6. Meni Meller

    Meni Meller Angel Fish

    # of Dives:
    Location: israel
    10
    1
    0
    UPDATE: strobes went to S&S for the update.
    problem reproduced, though after a large number of shots - about 70, was happening after about ten before.
    they were sent back again, and I received replacement strobes which I hope will be free of this problem, their SN is much higher comparing to the ones I had before.
     
  7. ivakdiver

    ivakdiver Barracuda

    # of Dives:
    Location: Niagara-On-The-Lake, Ontario, Canada
    412
    36
    28
    Glad your problem has been resolved. I'm having a heck of a time just getting my strobe to Sea and Sea for this update. The strobe has been 'on the road ' for over a month and presently seems to be going around in circles in San Francisco.
     

Share This Page