• Welcome to ScubaBoard


  1. Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

    Benefits of registering include

    • Ability to post and comment on topics and discussions.
    • A Free photo gallery to share your dive photos with the world.
    • You can make this box go away

    Joining is quick and easy. Login or Register now by clicking on the button

Smart Trak to Logtrak import

Discussion in 'SCUBAPRO' started by Nick Ruberg, Jun 18, 2017.

  1. conradb212

    conradb212 Angel Fish

    # of Dives: 200 - 499
    Location: Knoxville, TN area
    48
    6
    8
    I poked around a bit more on the SmartTrak/LogTrak situation. Here are some findings:

    I downloaded LogTrak onto one of my Windows 7 systems. LogTrak wanted Java, so I installed that. LogTrak didn't like the Java I installed. Turns out LogTrak wanted 32-bit Java even though I ran 64-bit Windows 7 on a 64-bit chip.

    LogTrak can import TravelTrak files with the .asd extension. SmartTrak can actually export TravelTrak files. So I selected all of my SmartTrak dives and exported them as a .asd file. Then I tried to open/import that file in LogTrak. LogTrak saw the file, began importing, but never got past 0% on the progress bar. There has to be a way, but I have not found it.

    Then I found that LogTrak supports not only Bluetooth and serial, but also IrDA. Lo and behold, LogTrak recognized my Galileo Sol via the Uwatec IrDA USB stick and read all dives into LogTrak. I was pleased, but not for long. I had about 350 dives on the Galileo, but LogTrak only read 123 of them. No idea yet why it didn't read all.

    As for LogTrak vs SmartTrak, biggest difference seems that LogTrak allows you to display the master list with all those dozens of variables that the Galileo tracks, whereas LogTrak displays just seven. I'd like to add more, but apparently that can't be done. It makes for a less cluttered look, and you can easily tab from Profile to Details to Location. But for now, LogTrak looks quite basic and unfinished.

    Overall, the big question I'd have is why go from the stable, mature SmartTrak that a great many divers use to a new piece of software that seems basic and does not appear to be terribly compatible. I'd like to know Uwatec's reason for that.

    I passed a number of these questions on to my Scubapro rep and hope to get answers.
     
  2. rjgiddings

    rjgiddings Nassau Grouper

    # of Dives: 200 - 499
    Location: Seattle
    109
    37
    28
    Joe Geiss - who is the sales rep for Scubapro said - many years ago that " sometimes SP makes something great/ fantastic and bulletproof that everyone loves- and and goes out of production way too quickly". And he was right...about just a few of their items. Still, I feel like Conrad b212 has nailed it with his post above.

    I used a Uwatec Smartcom that I had a USB IrDA stick from Frys electronics ($ 11.00) that I downloaded all my dives onto my PC. This was fantastic compared to the $ 99.99 version SP as selling. I printed every single dive and put them into plastic sleeves and into a three-ring binder.

    Now that I'm finally on Windows 10, I can say I'm watching this thread closely. When it comes to embracing the newest software, I'm always late to the party.
     
  3. MaxBottomtime

    MaxBottomtime Solo Diver

    # of Dives: 1,000 - 2,499
    Location: Torrance, CA
    8,367
    6,942
    113
    s-l500.jpg
    I got this one on Ebay for $30. I have Windows 10 and it worked as soon as I plugged it in, no problems whatsoever. I don't have Logtrac but it works great with Smartrac.
     
    rjgiddings likes this.
  4. Hatul

    Hatul Solo Diver

    # of Dives: 500 - 999
    Location: Tustin, California, United States
    4,019
    561
    113
    LogTrak totally sucks except for setting some parameters on the dive computer like your name and phone number. I migrated to Diving Log 6, which now supports the G2 and is good enough to finally leave my hand written log book.
     
  5. manosaa2

    manosaa2 Angel Fish

    # of Dives: 1,000 - 2,499
    Location: Athens, GREECE
    11
    1
    1
    DELETED
     
    Last edited: Oct 14, 2017
  6. LowDrag

    LowDrag Manta Ray

    # of Dives: 100 - 199
    Location: Portland, Oregon
    1,050
    171
    63
    I have been trying to download LogTRAK and all I get is, "we are amazed" and a404 turtle. I have stayed using the Diviac dive log here on Scubaboard.
     
  7. schumifan

    schumifan Angel Fish

    7
    2
    3
    I have Smartrak on a Windows 10 computer that is on its deathbed but it looks like I have to keep it alive because SP can't be bothered to stay in touch with what the users want/NEED.
    LogTrak is actually a pile of crap in comparison to SmarTrak. Scubapro have consistently failed to correctly support the software for their rather expensive computers.
    Now I have moved to Mac the fact that SmarTrak doesn't have a Mac version is the last straw.
    I have been a Scubapro user/advocate since the mid 70's but a divorce is now on the cards. The G2 looked like the natural successor to the Sol but the support is just not there.
    My next computer is now likely to be a Shearwater Perdix AL because at least, by reputation, Shearwater always support their products.
    Incidentally the SP IrDA issue was actually the fault of MS where in the early versions of Windows 10 they removed the IrDA stack claiming it was obsolete (maybe a point but still a lot of IrDA out here). I had to join their Insider program to get the revised versions with the stacks back in place. It was me hunting around for the solution that sorted out my issue. All I got from Scubapro were a few nondescript grunts an ahhs!
     
    Hatul likes this.
  8. elmo

    elmo DIR Practitioner

    # of Dives: 200 - 499
    Location: Melbourne
    124
    58
    28
    TTPaws likes this.
  9. atdotde

    atdotde Solo Diver

    # of Dives: 200 - 499
    Location: Munich, Germany
    131
    99
    28
    One should say though that Macs don't have IrDA (in the operating system) and thus Subsurface cannot connect via infrared on a Mac (even with a USB dongle).
     
  10. Mikey Bag O Donuts

    Mikey Bag O Donuts Angel Fish

    # of Dives: 0 - 24
    Location: Greenwich CT
    17
    0
    1
    I just bought my new G2 and have been able to export out of Smart Trak and input into LogTrak It was easy once you select the proper file to export to. (Travel Trak CE Log Book is the export type) When I went to look at my 100 dives I saw that only 53 were transferred. Anyone see this issue? I'm not sure how to proceed... Any help is appreciated...
     

Share This Page