• Welcome to ScubaBoard


  1. Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

    Benefits of registering include

    • Ability to post and comment on topics and discussions.
    • A Free photo gallery to share your dive photos with the world.
    • You can make this box go away

    Joining is quick and easy. Login or Register now by clicking on the button

sola photo 1200 can't be charging

Discussion in 'Light and Motion' started by HaHaHaM, Dec 1, 2013.

  1. HaHaHaM

    HaHaHaM Garibaldi

    # of Dives: 200 - 499
    Location: Hong Kong
    2
    0
    0
    Hi, My sola photo 1200 can't been charging, when I start charging it, just a few seconds the flashing red light become to all green light (Obviously it's not fully charged). I unplug the charger and that turn on the lighter, it become flashing red (it's almost out of power). Any suggest on this issue?


     
  2. drbill

    drbill The Lorax for the Kelp Forest Scuba Legend

    # of Dives: 2,500 - 4,999
    Location: Santa Catalina Island, CA
    22,441
    5,305
    113
    My chargers do the same thing... the light turns green quickly, but I leave them on for several hours and do get a decent charge. You might also check for corrosion in the charger ports on the light head. I think my batteries are nearing the end of their usable life so I may have to send the heads in to L&M to get new batteries pout in... but I've used mine for about two years with very frequent use (550 dives over the past two years).
     
  3. lightandmotion

    lightandmotion Dive Equipment Manufacturer

    46
    6
    0
    Hello HaHaHaM,
    I'm not completely clear on what you are seeing. When you unplug the light and turn it on, does the light's dashboard flash red twice, while the main LEDs stay off? If so, check out this FAQ on our website: Light & Motion || Lightlife

    If the light's main LEDs come on, but the battery status indicators begin to flash red, there could be two things going on:

    - If your contacts are corroded, you'll need to clean them; dirty contacts can't conduct electricity, and will not be able to charge the light. Check this FAQ for info on how to best clean them: Light & Motion || Lightlife

    - If the battery status indicators are blinking red, but the light seems to have its full burn life, then the battery's charge counter may be out of calibration. To re-calibrate it, charge the light fully (with clean contacts!) for three hours, and then run it all the way until it turns itself off. Then, recharge it fully again. This will reset the charge counter.

    If this still doesn't help, you can contact your dealer for information on getting the light serviced. Your account says you're located in Hong Kong--if so, our distributor Deep Blue Asia should be able to service the light for you.
     
  4. HaHaHaM

    HaHaHaM Garibaldi

    # of Dives: 200 - 499
    Location: Hong Kong
    2
    0
    0
    Thx all of you, it really helpful, and my problem have been solved!
    thx again!
     
  5. Chubbysmith

    Chubbysmith Garibaldi

    # of Dives: 50 - 99
    Location: Hong Kong
    1
    0
    0
    Thank you all! I was lazy and did not charge my Sola 1200 for a year. Tried last night and whilst the mains adaptor light glowed green, zilch on the Sola. After reading all your posts, I tried tapping the contacts of the torch with the prongs on the charger cable. After 3 taps I saw a red light flash on the torch as well as on the mains adaptor. I repeated this several times and got the same result. My battery was awake! I have left it on charge with three red lights flashing happily on the torch. I have diarized monthly charging for my Sola and my Ikelites!
     

Share This Page