• Welcome to ScubaBoard


  1. Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

    Benefits of registering include

    • Ability to post and comment on topics and discussions.
    • A Free photo gallery to share your dive photos with the world.
    • You can make this box go away

    Joining is quick and easy. Login or Register now by clicking on the button

Suunto Cobra3 odd behavior then failure

Discussion in 'Suunto' started by jsnyder, Jul 29, 2018.

  1. jsnyder

    jsnyder Angel Fish

    # of Dives: 200 - 499
    Location: Erie, PA
    13
    0
    1
    I’ve had my Cobra3 for just over 3 years and it has about 225 Dives on it (need to check log). About a year ago I pulled it out of a daily storage locker in Bonaire one morning lonely to find that around midnight it had decided I was dive no and it logged a nice, 0’, 8 hour dive. I cleaned it really well and all seemed to go back to normal except the temperature gauge never seemed to work right after that. ~50 Dives in the time since and all has been well....

    Today I was with students on a pool refresher in 12’ and I saw that Cobra hadn’t automatically gone into dive mode so I put it there manually. I looked down a little later and saw what looked like reasonable tank pressure reading but unit said 1’ in bottom when I was at 12’. Also, temperature reading showed ———.

    Has anyone seen anything like this before? Is there a master reset of some kind? Unit says battery is fine.

    Thoughts? Suggestions?
     

Share This Page