• Welcome to ScubaBoard


  1. Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

    Benefits of registering include

    • Ability to post and comment on topics and discussions.
    • A Free photo gallery to share your dive photos with the world.
    • You can make this box go away

    Joining is quick and easy. Login or Register now by clicking on the button

ys-01s with Oly xz-1: TTL??

Discussion in 'Sea&Sea' started by guyharrisonphoto, Apr 29, 2011.

  1. vossroad

    vossroad Solo Diver

    # of Dives: 50 - 99
    Location: League City TX
    91
    39
    18
    I just purchased the YS-01 for the TTL function on my XZ1. So, I'm a little confused w/ the results. Does the YS-01 work in TTL mode? If so, what do I set the camera flash function at, RC?
    Thanks for any response.
     
  2. cardog

    cardog Manta Ray

    # of Dives: 200 - 499
    Location: Enumclaw, Washington, United States
    801
    67
    28
    I just had mine set at manual, 1/64.
     
  3. guyharrisonphoto

    guyharrisonphoto ScubaBoard Supporter ScubaBoard Supporter

    # of Dives: 1,000 - 2,499
    Location: Florida, USA
    1,951
    1,033
    113
    The YS-01 WILL NOT, WILL NOT, WILL NOT operate in TTL exposure mode with the xz-1. Take it from me, tried everything. If you bought yours new, send them back. Go to qualified dealer like Reef Photo, and they will hook you up with Inon strobes that work perfectly.

    Because the strobes were worth more than the camera and housing, I sold the camera and went to E-PL2, which works fine with the ys-01s. However, if you can return the strobes for something that works you will be fine.
     

Share This Page