• Welcome to ScubaBoard


  1. Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

    Benefits of registering include

    • Ability to post and comment on topics and discussions.
    • A Free photo gallery to share your dive photos with the world.
    • You can make this box go away

    Joining is quick and easy. Login or Register now by clicking on the button

YS-D2 firing for no reason

Discussion in 'Sea&Sea Society' started by z00ropa, Aug 15, 2017.

  1. z00ropa

    z00ropa Angel Fish

    # of Dives: 500 - 999
    Location: Montclair CA
    19
    0
    1
    So I just bought a brand new YS-D2 strobe. When it's powered on and set to DS-TTL, not connected to a fiber optic cable, it will just fire. When it first comes on, after a few seconds it will fire, then a 30 seconds or so later it will fire a couple more times. It seems to stop the longer I leave it on, but is this normal?
     
  2. bvanant

    bvanant Loggerhead Turtle

    # of Dives:
    Location: Los Angeles (more or less)
    2,144
    323
    83
    No this is not normal in any way. Send it to get checked.
    Bill
     
  3. jmartel

    jmartel Angel Fish

    # of Dives: 100 - 199
    Location: Seattle, WA
    38
    16
    8
    Mine did this as well, only underwater. I was instructed to send it in for warranty work. You might want to contact whoever you bought the strobe from for warranty work.
     

Share This Page