• Welcome to ScubaBoard


  1. Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

    Benefits of registering include

    • Ability to post and comment on topics and discussions.
    • A Free photo gallery to share your dive photos with the world.
    • You can make this box go away

    Joining is quick and easy. Login or Register now by clicking on the button

750G LCD Display or Lens Issue

Discussion in 'Sea&Sea Society' started by sc_bubbles, Mar 31, 2019.

  1. sc_bubbles

    sc_bubbles Garibaldi

    # of Dives: 25 - 49
    Location: SC
    1
    0
    1
    Hi. I just bought a used 750G camera. I know it's old, but the price was good--$50 for camera, housing, and additional Sea Arm light kit. The only underwater camera I've used/owned previously is a little GoPro.

    I'm having issues with the LCD display on the Sea and Sea camera. I can see the Sea and Sea logo when I turn the camera on and all the little set up/camera function icons. However, I can't see anything through the lens and can't capture images on the SD card. I get a black screen, and the images are black on the card like you'd left the lens cap on. Except there's no lens cap. Any ideas if there is something I'm doing wrong, or is there a functionality issue with this camera? I plan to take it in to my not so local dive shop soon but thought I'd check here first to see if there is something I can trouble shoot on my own. Thanks for any feedback!

    Donna in SC
     

Share This Page