• Welcome to ScubaBoard


  1. Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

    Benefits of registering include

    • Ability to post and comment on topics and discussions.
    • A Free photo gallery to share your dive photos with the world.
    • You can make this box go away

    Joining is quick and easy. Login or Register now by clicking on the button

YS03 not working

Discussion in 'Sea&Sea' started by Martyn6, Jan 24, 2015.

  1. Martyn6

    Martyn6 Garibaldi

    2
    0
    0
    Hi guys, i just bought brand new ys03, first day worked ok, but second day on first dive worked like 10minutes, but after stopped firing after restart it worked for a while, but since then it is done the red led light do not light, it just blinks, now it blink red/green..
    tried to change batteries for new energizer, no help..
    any ideas? How it is with warranty ate seasea? Bought the item in thailand, but i ´m from europe..
    thanks a lot!
     

Share This Page